Ruby amqp gem and RabbitMQ versions compatibility

This Documentation Has Moved to rubyamqp.info

amqp gem documentation guides are now hosted on rubyamqp.info.

About this guide

This guide covers compatibility of the Ruby amqp gem with various versions of RabbitMQ messaging broker.

Covered versions

This guide covers Ruby amqp gem v0.8.0 and later.

RabbitMQ Version Requirement

amqp gem before 0.8.0 (0.6.x, 0.7.x) series implemented (most of) AMQP 0.8 specification. amqp gem 0.8.0 implements AMQP 0.9.1 and thus requires RabbitMQ version 2.0 or later. See RabbitMQ versions for more information about RabbitMQ versions support and how obtain up-todate packages for your operating system.

amqp gem 0.8.0 and later versions implement AMQP 0.9.1 and thus requires RabbitMQ version 2.0 or later

Using recent versions on Debian and Ubuntu

Ubuntu (even 10.10) and Debian both ship with an old RabbitMQ version, that only supports AMQP protocol 0.8. Ruby amqp gem 0.8.0 and later will not work with RabbitMQ versions before 2.0.0.

We strongly recommend that you use RabbitMQ apt repository that has recent versions of RabbitMQ.

OpsCode Chef & Puppet

Chef cookbook for RabbitMQ

There is a Chef cookbook for RabbitMQ that installs recent versions from the rabbitmq.com apt repository. It also has LWPRs (providers) for managing users and vhosts.

RabbitMQ Puppet module

There is a RabbitMQ Puppet module by the Puppet Labs team. It uses .deb packages from Debian testing and unstable repositories. Note that it has two dependencies:

TLS (SSL) support

Note that before 1.7.0, RabbitMQ did not support TLS. In order to have TLS support, RabbitMQ 1.7.0 requires

and recommends using Erlang R141B that ships with Erlang SSL 4.0.1. Learn more in our Using TLS (SSL) guide.

Authors

This guide was written by Michael Klishin and edited by Chris Duncan.

Tell us what you think!

Please take a moment and tell us what you think about this guide on Twitter or Ruby AMQP mailing list: what was unclear? what wasn’t covered? maybe you don’t like guide style or grammar and spelling are incorrect? Readers feedback is key to making documentation better.

If mailing list communication is not an option for you for some reason, you can contact guides author directly