Module: Sequel::DataObjects

Defined in:
lib/sequel/lib/sequel/adapters/do.rb,
lib/sequel/lib/sequel/adapters/do/mysql.rb,
lib/sequel/lib/sequel/adapters/do/sqlite.rb,
lib/sequel/lib/sequel/adapters/do/postgres.rb

Overview

Module holding the DataObjects support for Sequel. DataObjects is a ruby library with a standard API for accessing databases.

The DataObjects adapter currently supports PostgreSQL, MySQL, and SQLite:

Defined Under Namespace

Modules: MySQL, Postgres, SQLite Classes: Database, Dataset

Constant Summary collapse

DATABASE_SETUP =

Contains procs keyed on sub adapter type that extend the given database object so it supports the correct database type.

{:postgres=>proc do |db|
    require 'do_postgres'
    Sequel.require 'adapters/do/postgres'
    db.extend(Sequel::DataObjects::Postgres::DatabaseMethods)
  end,
  :mysql=>proc do |db|
    require 'do_mysql'
    Sequel.require 'adapters/do/mysql'
    db.extend(Sequel::DataObjects::MySQL::DatabaseMethods)
  end,
  :sqlite3=>proc do |db|
    require 'do_sqlite3'
    Sequel.require 'adapters/do/sqlite'
    db.extend(Sequel::DataObjects::SQLite::DatabaseMethods)
  end
}