Shared classes and tests for fog providers and services.
Fog-core requires Ruby
2.0.0 or later.
1.9 support was dropped in
fog-v2.0.0 as a backwards incompatible
change. Please use the later fog
1.x versions if you require
Add this line to your application's Gemfile:
And then execute:
Or install it yourself as:
$ gem install fog-core
fog-core's dependencies have dropped support for Ruby 1.9.3 in later
versions. Rather than limit all
fog users to older but compatible versions,
if you are using 1.9.3 you will need to declare a compatible version in your
gem "net-ssh", "< 3.0"
Gemfile.1.9.3 for the definitive list as tested by Travis.
TODO: Write usage instructions here
- Fork it ( http://github.com/fog/fog-core/fork )
- Create your feature branch (
git checkout -b my-new-feature)
- Commit your changes (
git commit -am 'Add some feature')
- Push to the branch (
git push origin my-new-feature)
- Create new Pull Request