Class: Google::Apis::AndroidenterpriseV1::AutoInstallPolicy

Inherits:
Object
  • Object
show all
Includes:
Core::Hashable, Core::JsonObjectSupport
Defined in:
generated/google/apis/androidenterprise_v1/classes.rb,
generated/google/apis/androidenterprise_v1/representations.rb,
generated/google/apis/androidenterprise_v1/representations.rb

Instance Attribute Summary collapse

Instance Method Summary collapse

Methods included from Core::JsonObjectSupport

#to_json

Methods included from Core::Hashable

process_value, #to_h

Constructor Details

#initialize(**args) ⇒ AutoInstallPolicy

Returns a new instance of AutoInstallPolicy.


590
591
592
# File 'generated/google/apis/androidenterprise_v1/classes.rb', line 590

def initialize(**args)
   update!(**args)
end

Instance Attribute Details

#auto_install_constraintArray<Google::Apis::AndroidenterpriseV1::AutoInstallConstraint>

The constraints for auto-installing the app. You can specify a maximum of one constraint. Corresponds to the JSON property autoInstallConstraint


569
570
571
# File 'generated/google/apis/androidenterprise_v1/classes.rb', line 569

def auto_install_constraint
  @auto_install_constraint
end

#auto_install_modeString

The auto-install mode. If unset defaults to "doNotAutoInstall". Corresponds to the JSON property autoInstallMode

Returns:

  • (String)

574
575
576
# File 'generated/google/apis/androidenterprise_v1/classes.rb', line 574

def auto_install_mode
  @auto_install_mode
end

#auto_install_priorityFixnum

The priority of the install, as an unsigned integer. A lower number means higher priority. Corresponds to the JSON property autoInstallPriority

Returns:

  • (Fixnum)

580
581
582
# File 'generated/google/apis/androidenterprise_v1/classes.rb', line 580

def auto_install_priority
  @auto_install_priority
end

#minimum_version_codeFixnum

The minimum version of the app. If a lower version of the app is installed, then the app will be auto-updated according to the auto-install constraints, instead of waiting for the regular auto-update. You can set a minimum version code for at most 20 apps per device. Corresponds to the JSON property minimumVersionCode

Returns:

  • (Fixnum)

588
589
590
# File 'generated/google/apis/androidenterprise_v1/classes.rb', line 588

def minimum_version_code
  @minimum_version_code
end

Instance Method Details

#update!(**args) ⇒ Object

Update properties of this object


595
596
597
598
599
600
# File 'generated/google/apis/androidenterprise_v1/classes.rb', line 595

def update!(**args)
  @auto_install_constraint = args[:auto_install_constraint] if args.key?(:auto_install_constraint)
  @auto_install_mode = args[:auto_install_mode] if args.key?(:auto_install_mode)
  @auto_install_priority = args[:auto_install_priority] if args.key?(:auto_install_priority)
  @minimum_version_code = args[:minimum_version_code] if args.key?(:minimum_version_code)
end