Class: Google::Apis::AndroidmanagementV1::AdvancedSecurityOverrides

Inherits:
Object
  • Object
show all
Includes:
Core::Hashable, Core::JsonObjectSupport
Defined in:
generated/google/apis/androidmanagement_v1/classes.rb,
generated/google/apis/androidmanagement_v1/representations.rb,
generated/google/apis/androidmanagement_v1/representations.rb

Overview

Security policies set to the most secure values by default. To maintain the security posture of a device, we don't recommend overriding any of the default values.

Instance Attribute Summary collapse

Instance Method Summary collapse

Methods included from Core::JsonObjectSupport

#to_json

Methods included from Core::Hashable

process_value, #to_h

Constructor Details

#initialize(**args) ⇒ AdvancedSecurityOverrides

Returns a new instance of AdvancedSecurityOverrides.


37
38
39
# File 'generated/google/apis/androidmanagement_v1/classes.rb', line 37

def initialize(**args)
   update!(**args)
end

Instance Attribute Details

#untrusted_apps_policyString

The policy for untrusted apps (apps from unknown sources) enforced on the device. Replaces install_unknown_sources_allowed (deprecated). Corresponds to the JSON property untrustedAppsPolicy

Returns:

  • (String)

35
36
37
# File 'generated/google/apis/androidmanagement_v1/classes.rb', line 35

def untrusted_apps_policy
  @untrusted_apps_policy
end

Instance Method Details

#update!(**args) ⇒ Object

Update properties of this object


42
43
44
# File 'generated/google/apis/androidmanagement_v1/classes.rb', line 42

def update!(**args)
  @untrusted_apps_policy = args[:untrusted_apps_policy] if args.key?(:untrusted_apps_policy)
end