Class: Google::Apis::AndroidmanagementV1::ApiLevelCondition

Inherits:
Object
  • Object
show all
Includes:
Core::Hashable, Core::JsonObjectSupport
Defined in:
generated/google/apis/androidmanagement_v1/classes.rb,
generated/google/apis/androidmanagement_v1/representations.rb,
generated/google/apis/androidmanagement_v1/representations.rb

Overview

A compliance rule condition which is satisfied if the Android Framework API level on the device doesn't meet a minimum requirement. There can only be one rule with this type of condition per policy.

Instance Attribute Summary collapse

Instance Method Summary collapse

Methods included from Core::JsonObjectSupport

#to_json

Methods included from Core::Hashable

process_value, #to_h

Constructor Details

#initialize(**args) ⇒ ApiLevelCondition

Returns a new instance of ApiLevelCondition.


86
87
88
# File 'generated/google/apis/androidmanagement_v1/classes.rb', line 86

def initialize(**args)
   update!(**args)
end

Instance Attribute Details

#min_api_levelFixnum

The minimum desired Android Framework API level. If the device doesn't meet the minimum requirement, this condition is satisfied. Must be greater than zero. Corresponds to the JSON property minApiLevel

Returns:

  • (Fixnum)

84
85
86
# File 'generated/google/apis/androidmanagement_v1/classes.rb', line 84

def min_api_level
  @min_api_level
end

Instance Method Details

#update!(**args) ⇒ Object

Update properties of this object


91
92
93
# File 'generated/google/apis/androidmanagement_v1/classes.rb', line 91

def update!(**args)
  @min_api_level = args[:min_api_level] if args.key?(:min_api_level)
end