Class: Brakeman::CheckNumberToCurrency

Inherits:
BaseCheck show all
Defined in:
lib/brakeman/checks/check_number_to_currency.rb

Constant Summary

Constants inherited from BaseCheck

BaseCheck::CONFIDENCE

Constants included from Util

Util::ALL_PARAMETERS, Util::COOKIES, Util::COOKIES_SEXP, Util::PARAMETERS, Util::PARAMS_SEXP, Util::PATH_PARAMETERS, Util::QUERY_PARAMETERS, Util::REQUEST_ENV, Util::REQUEST_PARAMETERS, Util::REQUEST_PARAMS, Util::SESSION, Util::SESSION_SEXP

Constants inherited from SexpProcessor

SexpProcessor::VERSION

Instance Attribute Summary

Attributes inherited from BaseCheck

#tracker, #warnings

Attributes inherited from SexpProcessor

#context, #env, #expected

Instance Method Summary collapse

Methods inherited from BaseCheck

#add_result, inherited, #initialize, #process_call, #process_cookies, #process_default, #process_if, #process_params, #process_string_interp

Methods included from Util

#array?, #block?, #call?, #camelize, #contains_class?, #context_for, #cookies?, #false?, #file_by_name, #file_for, #github_url, #hash?, #hash_access, #hash_insert, #hash_iterate, #integer?, #make_call, #node_type?, #number?, #params?, #pluralize, #regexp?, #relative_path, #request_env?, #request_value?, #result?, #set_env_defaults, #sexp?, #string?, #symbol?, #table_to_csv, #template_path_to_name, #true?, #truncate_table, #underscore

Methods included from ProcessorHelper

#class_name, #process_all, #process_all!, #process_call_args, #process_class, #process_module

Methods inherited from SexpProcessor

#error_handler, #in_context, #initialize, #process, #process_dummy, #scope

Constructor Details

This class inherits a constructor from Brakeman::BaseCheck

Instance Method Details

#check_helper_option(result, exp) ⇒ Object


51
52
53
54
55
56
57
58
59
# File 'lib/brakeman/checks/check_number_to_currency.rb', line 51

def check_helper_option result, exp
  if match = (has_immediate_user_input? exp or has_immediate_model? exp)
    match = match.match if match.is_a? Match
    warn_on_number_helper result, match
    @found_any = true
  else
    false
  end
end

#check_number_helper_usageObject


37
38
39
40
41
42
43
44
45
46
47
48
49
# File 'lib/brakeman/checks/check_number_to_currency.rb', line 37

def check_number_helper_usage
  number_methods = [:number_to_currency, :number_to_percentage, :number_to_human] 
  tracker.find_call(:target => false, :methods => number_methods).each do |result|
    arg = result[:call].second_arg
    next unless arg

    if not check_helper_option(result, arg) and hash? arg
      hash_iterate(arg) do |key, value|
        break if check_helper_option(result, value)
      end
    end
  end
end

#generic_warningObject


20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
# File 'lib/brakeman/checks/check_number_to_currency.rb', line 20

def generic_warning
  message = "Rails #{tracker.config[:rails_version]} has a vulnerability in number helpers (CVE-2014-0081). Upgrade to Rails version "

  if version_between? "2.3.0", "3.2.16"
    message << "3.2.17"
  else
    message << "4.0.3"
  end

  warn :warning_type => "Cross Site Scripting",
    :warning_code => :CVE_2014_0081,
    :message => message,
    :confidence => CONFIDENCE[:med],
    :gem_info => gemfile_or_environment,
    :link_path => "https://groups.google.com/d/msg/ruby-security-ann/9WiRn2nhfq0/2K2KRB4LwCMJ"
end

#run_checkObject


8
9
10
11
12
13
14
15
16
17
18
# File 'lib/brakeman/checks/check_number_to_currency.rb', line 8

def run_check
  if version_between? "2.0.0", "2.3.18" or
    version_between? "3.0.0", "3.2.16" or
    version_between? "4.0.0", "4.0.2"

    return if lts_version? "2.3.18.8"

    check_number_helper_usage
    generic_warning unless @found_any
  end
end

#warn_on_number_helper(result, match) ⇒ Object


61
62
63
64
65
66
67
68
69
# File 'lib/brakeman/checks/check_number_to_currency.rb', line 61

def warn_on_number_helper result, match
  warn :result => result,
    :warning_type => "Cross Site Scripting",
    :warning_code => :CVE_2014_0081_call,
    :message => "Format options in #{result[:call].method} are not safe in Rails #{@tracker.config[:rails_version]}",
    :confidence => CONFIDENCE[:high],
    :link_path => "https://groups.google.com/d/msg/ruby-security-ann/9WiRn2nhfq0/2K2KRB4LwCMJ",
    :user_input => match
end