Class: Brakeman::CheckYAMLParsing

Inherits:
BaseCheck show all
Defined in:
lib/brakeman/checks/check_yaml_parsing.rb

Constant Summary

Constants inherited from BaseCheck

BaseCheck::CONFIDENCE

Constants included from Util

Util::ALL_PARAMETERS, Util::COOKIES, Util::COOKIES_SEXP, Util::PARAMETERS, Util::PARAMS_SEXP, Util::PATH_PARAMETERS, Util::QUERY_PARAMETERS, Util::REQUEST_ENV, Util::REQUEST_PARAMETERS, Util::REQUEST_PARAMS, Util::SESSION, Util::SESSION_SEXP

Constants inherited from SexpProcessor

SexpProcessor::VERSION

Instance Attribute Summary

Attributes inherited from BaseCheck

#tracker, #warnings

Attributes inherited from SexpProcessor

#context, #env, #expected

Instance Method Summary collapse

Methods inherited from BaseCheck

#add_result, inherited, #initialize, #process_call, #process_cookies, #process_default, #process_if, #process_params, #process_string_interp

Methods included from Util

#array?, #block?, #call?, #camelize, #contains_class?, #context_for, #cookies?, #false?, #file_by_name, #file_for, #github_url, #hash?, #hash_access, #hash_insert, #hash_iterate, #integer?, #make_call, #node_type?, #number?, #params?, #pluralize, #regexp?, #relative_path, #request_env?, #request_value?, #result?, #set_env_defaults, #sexp?, #string?, #symbol?, #table_to_csv, #template_path_to_name, #true?, #truncate_table, #underscore

Methods included from ProcessorHelper

#class_name, #process_all, #process_all!, #process_call_args, #process_class, #process_module

Methods inherited from SexpProcessor

#error_handler, #in_context, #initialize, #process, #process_dummy, #scope

Constructor Details

This class inherits a constructor from Brakeman::BaseCheck

Instance Method Details

#disabled_xml_dangerous_types?Boolean

Returns:

  • (Boolean)

97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
# File 'lib/brakeman/checks/check_yaml_parsing.rb', line 97

def disabled_xml_dangerous_types?
  if version_between? "0.0.0", "2.3.14"
    matches = tracker.check_initializers(:"ActiveSupport::CoreExtensions::Hash::Conversions::XML_PARSING", :delete)
  else
    matches = tracker.check_initializers(:"ActiveSupport::XmlMini::PARSING", :delete)
  end

  symbols_off = false
  yaml_off = false

  matches.each do |result|
    arg = result.call.first_arg

    if string? arg
      if arg.value == "yaml"
        yaml_off = true
      elsif arg.value == "symbol"
        symbols_off = true
      end
    end
  end

  symbols_off and yaml_off
end

#disabled_xml_parser?Boolean

Returns:

  • (Boolean)

48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
# File 'lib/brakeman/checks/check_yaml_parsing.rb', line 48

def disabled_xml_parser?
  if version_between? "0.0.0", "2.3.14"
    #Look for ActionController::Base.param_parsers.delete(Mime::XML)
    params_parser = s(:call,
                      s(:colon2, s(:const, :ActionController), :Base),
                      :param_parsers)

    matches = tracker.check_initializers(params_parser, :delete)
  else
    #Look for ActionDispatch::ParamsParser::DEFAULT_PARSERS.delete(Mime::XML)
    matches = tracker.check_initializers(:"ActionDispatch::ParamsParser::DEFAULT_PARSERS", :delete)
  end

  unless matches.empty?
    mime_xml = s(:colon2, s(:const, :Mime), :XML)

    matches.each do |result|
      if result.call.first_arg == mime_xml
        return true
      end
    end
  end

  false
end

#enabled_yaml_parser?Boolean

Look for ActionController::Base.param_parsers = :yaml in Rails 2.x apps

Returns:

  • (Boolean)

76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
# File 'lib/brakeman/checks/check_yaml_parsing.rb', line 76

def enabled_yaml_parser?
  param_parsers = s(:call,
                    s(:colon2, s(:const, :ActionController), :Base),
                    :param_parsers)

  matches = tracker.check_initializers(param_parsers, :[]=)

  mime_yaml = s(:colon2, s(:const, :Mime), :YAML)

  matches.each do |result|
    if result.call.first_arg == mime_yaml and
      symbol? result.call.second_arg and
      result.call.second_arg.value == :yaml

      return true
    end
  end

  false
end

#run_checkObject


8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
# File 'lib/brakeman/checks/check_yaml_parsing.rb', line 8

def run_check
  return unless version_between? "0.0.0", "2.3.14" or
                version_between? "3.0.0", "3.0.18" or
                version_between? "3.1.0", "3.1.9" or
                version_between? "3.2.0", "3.2.10"

  unless disabled_xml_parser? or disabled_xml_dangerous_types?
    new_version = if version_between? "0.0.0", "2.3.14"
                    "2.3.15"
                  elsif version_between? "3.0.0", "3.0.18"
                    "3.0.19"
                  elsif version_between? "3.1.0", "3.1.9"
                    "3.1.10"
                  elsif version_between? "3.2.0", "3.2.10"
                    "3.2.11"
                  end

    message = "Rails #{tracker.config[:rails_version]} has a remote code execution vulnerability: upgrade to #{new_version} or disable XML parsing"

    warn :warning_type => "Remote Code Execution",
      :warning_code => :CVE_2013_0156,
      :message => message,
      :confidence => CONFIDENCE[:high],
      :gem_info => gemfile_or_environment,
      :link_path => "https://groups.google.com/d/topic/rubyonrails-security/61bkgvnSGTQ/discussion"
  end

  #Warn if app accepts YAML
  if version_between?("0.0.0", "2.3.14") and enabled_yaml_parser?
    message = "Parsing YAML request parameters enables remote code execution: disable YAML parser"

    warn :warning_type => "Remote Code Execution",
      :warning_code => :CVE_2013_0156,
      :message => message,
      :confidence => CONFIDENCE[:high],
      :gem_info => gemfile_or_environment,
      :link_path => "https://groups.google.com/d/topic/rubyonrails-security/61bkgvnSGTQ/discussion"
  end
end