ShopifyUtil

Shopify API Version Build Status Inline docs

Useful interactions with Shopify.

Installation

ruby gem 'shopify_util', '~> 0.1.0'

Configuration

```ruby # config/initializers/shopify_util.rb

ShopifyUtil.configure do |config| shopify_vars = Rails.application.credentials[Rails.env.to_sym][:shopify] config.api_key = shopify_vars[:api_key] config.shop_name = shopify_vars[:shop_name] config.password = shopify_vars[:api_password] config.api_version = shopify_vars[:api_version] config.data_dir = ActiveStorage::Blob.service.root end ```

Contributing

Bug reports and pull requests are welcome on GitHub at https://github.com/tcd/shopify_util.

License

The gem is available as open source under the terms of the MIT License.