Module: Net::SSH::Transport::Kex::Curve25519Sha256Loader

Defined in:
lib/net/ssh/transport/kex/curve25519_sha256_loader.rb

Overview

Loads Curve25519Sha256 support which requires optinal dependencies

Class Method Summary collapse

Class Method Details

.dependenciesRequiredForX25519Object


22
23
24
25
# File 'lib/net/ssh/transport/kex/curve25519_sha256_loader.rb', line 22

def self.dependenciesRequiredForX25519
  result = "net-ssh requires the following gems for x25519 support:\n"
  result << " * x25519\n"
end

.raiseUnlessLoaded(message) ⇒ Object

Raises:

  • (NotImplementedError)

16
17
18
19
20
# File 'lib/net/ssh/transport/kex/curve25519_sha256_loader.rb', line 16

def self.raiseUnlessLoaded(message)
  description = ERROR.is_a?(LoadError) ? dependenciesRequiredForX25519 : ''
  description << "#{ERROR.class} : \"#{ERROR.message}\"\n" if ERROR
  raise NotImplementedError, "#{message}\n#{description}" unless LOADED
end